Video Editor unavailable

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 10:10 EDT

Investigating

We are currently investigating an issue with the Editor being partially unavailable for some users
Posted Mar 31, 2025 - 09:44 EDT
This incident affected: Create, Record, and Interactive.