Uploads may not be working due to a Dropbox platform issue

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Apr 25, 2023 - 17:22 EDT

Investigating

We are currently investigating this issue.
Posted Apr 25, 2023 - 13:18 EDT
This incident affected: Upload.