Issue with AI translations

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 17:16 EDT

Investigating

We are currently investigating AI translation jobs stalling
Posted Mar 26, 2025 - 16:38 EDT
This incident affected: Website.