VOD Analytics Failing for Non-Enterprise users

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 11:56 EDT

Investigating

We are currently investigating this issue.
Posted Apr 04, 2025 - 11:31 EDT
This incident affected: VOD Analytics.